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 Select data (ctrl + A)
 Copy data (ctrl + C)

 Open Data Editor (Edit) Mode
 Press (ctrl + V) to paste 
 Select “Variable Names” (for first row)

Import data from Excel



Import data from Excel

Keep in mind that
 Missing data should be blank in excel
 Missing data will be automatically dot (.) in Stata
 There should be no space in variable names
 Label variables after importing from excel



Examining data

• browse: br variable_names
• edit: ed variable_names
• describe: des variable_names
• inspect: ins variable_names
• codebook: codebook variable_names
• List in result window: list variable_names
• Count observations: count

• br variable_names in 1/10
• ins variable_names in f/5
• codebook variable_names in -5/l
• list variable_names in 11/20

Using “in”



Relational operators

• br variable_names if dhs==.
• br variable_names if dhs!=.
• count if minc<5000
• count if mexpd>=5000



Labelling variables

lab var fs "family size (number of hh members)"

lab define shhh_lbl 1 "Male" 2 "Female"
lab values shhh shhh_lbl

Labelling values

Variable name Label name

Variable name
Label description

Value



rename variable, replace values

Command: rename old_name new_name
Example: rename shhh gender

Keeping variables: keep psu hh hhid fs nc gender eduhhh minc mexpd
Or, dropping variables: drop dhs
Keeping observations: keep if minc!=.
Or, dropping observations: drop if minc==.

keep / drop variables or observations

Get average minc: tabstat minc
Replace missing value: replace minc=2704.125 if minc==.
Undo manually: replace minc=. if minc==2704.125



Generating variable

….using arithmetic operator

• gen msav=minc-mexpd
• gen msavsq=msav^2
• gen pc_minc=minc/fs
• gen msav_rate=msav/minc if minc!=0

• gen fdummy=.
• replace fdummy=1 if gender==2
• replace fdummy=0 if gender==1

can use “recode” instead



Generating variable

….using function

• gen lminc=log(minc)
• gen amsav=abs(msav)

Function for gen command Use

log(x) or ln(x) (Natural) logarithm of x

abs(x) Absolute value of x

exp(x) Antilog of x

int(x) Truncation to integer value

round(x) Rounds to the nearest integer

round(x,y) x rounded in y decimal place

sqrt(x) Square root of x

• egen avgminc=mean(minc)
• gen gavgminc=mean(minc), by(gender)
……………………………………………………….…………………………………more details later with household survey data

“egen”= extended generation



Recode variable

….to categorize

recode eduhhh (min/5=1 “Primary”) (6/10=2 “Secondary”) (11/12=3 “Highersecondary”) (13/max=4 “Graduation”), gen(educ)

recode gender (1=0) (2=1), gen(fdummy2)



Logical operators

….after “if”

br if gender==1 & minc >5000

gen dummy=0
replace dummy=1 if minc>5000 | mexpd>5000



Order & Sort

order psu hh hhid minc mexpd

sort gender fs
sort psu hh

order variables at the beginning of the dataset

sort observations by values



Data Types

Qualitative/Categorical

Nominal

Ordinal

Quantitative/Numerical

Discrete

Continuous

Gender

Education

Family size

Height

Language Shoe size

TemperatureLikert scale



Descriptive statistics: categorical



Descriptive statistics: numerical

hist minc, norm

ssc install univar



Get help, find/install packages, and more..

• ssc install extremes
• extremes minc
• ssc uninstall extremes

• ssc hot

• ssc install asdoc
• findit asdoc
• help asdoc
• help reg



Working directory

Before doing anything with an open Stata file, you should always define the location of your

working folder. Your ‘working folder’ is a folder on (one of) your drives where you keep all of

your data for a particular project or piece of analysis.

If you have never been so organized with your data sets, now is an excellent time to start! Doing

a bunch of analyses using multiple datasets and having the files all jumbled in with other

documents or spread all over the place in separate folders is not a correct way to use Stata!

Check current working directory with the command:

Change working directory:

Go to File ⇒ Change Working Directory ⇒ Select specific folder.
Or, use following command:

pwd

cd "…folder path…\filename"



Do file

What is Do File?

Do files are simply text files whose names end with .do and which contain Stata commands exactly the way

you'd type them into the command window. Sometimes people call them programs, though Stata uses this

term for something else. You can write do files using any text editor, but the Do File Editor built into Stata has

tools and features designed to help programmers so we recommend using it. Do not write Stata code using

Word—it will automatically insert things like "smart quotes" and other formatting that Stata cannot

understand. You should save all your commands (total workflow) in a do file.

Starting a Do file:

Start the Do File Editor by clicking on the button that looks like a pencil writing in a notebook or by typing

doedit in the command line. Alternatively use Window⇒ Do-file editor.

Use File ⇒ Open, from within the editor and look for the desired file. Alternatively, in the Review window you

should see a copy of the command that was generated while executing commands. Copy this command and paste it

into the do file. Save this file using File ⇒ Save, from within the do file editor. Only through this way, your

commands will not disappear after quitting Stata.



Do file

Setting Up:

Almost every do file should start with the following commands (or something very much like them):

clear all 

set more off

The first command clears the memory so you don't have to worry about what might have happened before
your do file was run. The second tells Stata not to pause whenever the screen fills and wait for you to press a
key.

Loading Data:

Next you will usually load a data set:

If the dataset is in the current working directory, you don't need to specify its location.

use dataset_name.dta

Do Your Work:

At this point you'll be ready to do your work. Generally, this means data preparation, exploratory analysis, or
analysis you intend to report or publish. We recommend you to use do file for this. Write the commands in the
do file serially.



Do file

Save your new dataset:

You may need to save your work (new data file after all the modifications) at the end:

The replace option again allows Stata to overwrite the output from previous attempts to run the do

file. Otherwise, the do file will not run 2nd time because there is already a dataset with that name.

Never, ever save your output data set over your input data set. (In other words, the starting use

command and the ending save command should never act on the same file.) If you do, the data set

your do file was written to work with will no longer exist. If it turns out you made a mistake, you can't

easily recover.

Clearing everything from memory, loading the data set you want to use, and then saving any changes

you make to a different file (with different name) makes your do file reproducible. You can run it again

any time you want and get the exact same results. If the input data set changes, you'll be applying the

exact same procedures to the new data. If it turns out you made a mistake, all you need to do is

correct the error in your code and run the do file again. If you need to make changes you can do so

without starting over. It may take a bit of effort at first to get into the habit of writing reproducible

code, but the effort will pay off very quickly.

save new_dataset_name.dta, replace



Do file

Comments in Do file:

Comments are text included in a do file for the benefit of human readers, not for Stata. Comments can
explain what the do file does and why, and if anyone else ever needs to read and understand your do file
they'll be very grateful for good comments. Or you are the most beneficiary of your comments, when you
have to figure out how your do file works months or years after writing it. Be sure to comment any code that
required particular cleverness to write.
Comments need to be marked as such so that Stata will not try to execute them. /* means Stata should
ignore everything until it sees */, while // means Stata should ignore the rest of that line. Here's how one
might comment:

//make a list of cars I might be interested in buying

list make price mpg rep78 if price<4000 | (price<5000 & rep78>3 & rep78<.)

/* Note:

Some cars will appear on the list even though they have a missing value 

for rep78.

This is not an error.

If their price is less than $4,000 I don't care about their

repair record.

*/



Do file

Save Do file: 
File ⇒ Save as (In do file window)

Running a Do File:

The easiest way to run a do file is to press Ctrl+d in the Do File Editor, or click the icon on the far

right that looks like a "play" button over some code. If you first select just part of the do file

then only that part will be run.

Running parts of your code rather than the entire do file can save a lot of time, but code taken

out of context won't always work. For example, if you run a command that creates a variable x,

realize you made a mistake, and then fix it, you can't simply select that command and run it

again unless you first drop the existing version of x. If you find yourself getting confused by these

kinds of issues, run the entire do file rather than a selection so everything is run in its proper

context with appropriate serial.



Log file

What is Log File?

It is used to keep a record of the results obtained while using Stata. A research do file should have a

corresponding log file which records all the commands the do file ran along with their results.

Start a Log:

To start logging, the command is:

where logfilename is the name of the file you want Stata to use as a log. Give the log file the

same name as the do file it records, so it's obvious which log file goes with which do file.

The replace option will overwrite the previous version. Alternatively, an append option will

add to the previous contents of the log file.

Then do your work using do file.

Close your Log:

The command is:

Or, go to File⇒ Log⇒ Close

log using logfilename.log, replace

log close



Merge & Append

……Joining two datasets together

Merge Append

Adds variables/columns Adds observations/rows

Master file
Using file



• Append adds cases/observations to a dataset by joining two datasetstogether.

• In Append, we join two datasets:

– Master file: the data file with which we will append the other file

– Using file: the data file we will be appending with the master file.

• To append a using file with a master file, they must have:

• Common variables with same name in two datasets for all observations.

• Each variable must be in the same format in both the master file and the using  file.

• If you attempt to append a using dataset with variables that do not match with the master dataset, they will be 

added to the appended dataset as additional variables. 

Append



Append

Appended DatasetMaster file

Using file



Merge

• Merge adds variables to a dataset by joining two datasetstogether.
• In merge, we join two datasets:

– Master file: the data file with which we will merge the other file
– Using file: the data file we will be merging with the master file.

• To merge a using file with a master file, they must have:
• At least a common variable (key variable) based on which we will merge.
• There can be more than one key variables
• The key variables must have the samename.

• Thevariable must be in the sameformat in both the master file and the using  file.

• If they are in string (alphanumeric) format in the both the files, their spelling must be  same (i.e. country names,
etc).

• Merge could be of four types:
– 1:1 (one to one) merge, m:1 (many to one) merge, 1:m (one to many) merge and m:m (many to many) merge. 



Merge (1:1)

Master file Using file

Merged dataset
(One to One)

1:1



Merge (1:m)

Using file

Master file

Merged dataset
(One to Many)

1:m



Thank you!


